Scancommander Restauration - Ni-Cd Akku durch was anderes ersetzen?

  • Die Durchkontaktierungen lassen sich ja relativ easy reparieren. Dünnes Drähtchen durch und von beiden Seiten verlöten. Gut, das die noch nicht Multilayer sind.

    Ja, ist noch richtige Schlosserei-Elektronik.

    Das Problem bei den Durchkontaktierungen ist hauptsächlich, dass trotz Reinigung dort immer noch Reste von Elektrolyt drin sind und/oder die Verzinnung der Oberflächen beschädigt ist. Messtechnisch und auch optisch unter dem Mikroskop sind die Durchkontaktierungen durchaus in Ordnung. Mit Luftsauerstoff oxydiert das aber munter weiter. Und bei Veranstaltungen ist nicht nur Sauerstoff als Gas in der Luft...

    Zuverlässig ist das leider nicht mehr. Die Leiterplatte bekommt jetzt erst einmal ein Ultraschallbad mit Elektronikreiniger und nach Reparatur eine dicke Schicht Schutzlack.


    Der LC lief nach der ersten Reparatur mal 2 Jahre problemlos, dann wieder ein Totalausfall.


    Falls also jemand eine Leiterplatte mit etwas lokalerer Beschädigung übrig hat könnte ich die jetzige Leiterplatte als Dekorationselement an die Wand meiner Elektronikwerkstatt hängen.

  • Das Elektrolyt sollte beim löten aber verdampfen. Das Lötzinn zieht in der Regel in die Hohlniete rein.

    Tut er auch, allerdings nur der flüssige Anteil, zurück bleiben Salze, die wieder Wasser ziehen. Ich habe auch nicht alle Durchkontaktierungen prophylaktisch nachgelötet. Leider benetzt Lötzinn trotz Flussmittel das oxidierte Kupfer oder Zinn fast gar nicht und zieht bei angegriffenen Durchkontaktierungen dann nicht sauber rein.

  • Moin,


    es geht weiter:


    der Akku ist ersetzt - funktioniert (das Reichelt-Teil)


    Phänomen: es funktionieren einige Tasten nicht, z.B. "STORE", "QUIT" & "OPTIONS".

    Interessant: auf dem komplett auf Werkseinstellung zurückgesetzten Gerät sind die Funktionen der "QUIT"-Taste und der "OPTIONS"-Taste auf 2 Macro-Tasten gelegt (worden?!) Auf der Tastaturplatine kann ich aber keine Veränderung erkennen, und daß die Taster verschleißen gehört ja wohl ins Buch der Legenden. Ich habe die Taster einzeln durchgemessen, die schließen bei Betätigung.


    Ideen, woran das liegen könnte?


    2. Phänomen: Das Display ist invertiert. Es ist vielleicht mal ersetzt worden, aber kann man das via Jumper invertieren, um einen "Dark-Modus" zu erhalten? oder ist da eine Polarisationsfolie verkehrt herum?


    ue7mbetm.jpg


    skippa

  • Kannst du den Kontrast vom Display verstellen ?

    Moin,


    ja, der Kontrastregler funktioniert, aber es ist definitiv invertiert. Das mit den Signalen der Taster wird aufwendig - möglicherweise findet sich aber irgendwo ein Schaltplan des Facepanel. Hab noch einen zweiten Scancommander im Keller stehen, ich werd mal probehalber die Facepanel hin und her tauschen.


    skippa

  • Moin,


    hier mal ein Zwischenstand zum Thema Scancommander Display.


    In dem Restaurationsobejekt ist nur scheinbar ein TLX-1741-C3B drin, denn wenn man den Aufkleber mit der Typenbezeichnung abpult kommt darunter die "echte" Prduktbezeichnung und auch der Hersteller zum Vorschein:


    NAN YA Plastics Corp. M014-D


    Also ein Ersatzdisplay, kein echtes, originales Toshiba-Display, was ab Werk in den ScanCos verbaut wurde. Schade.


    Nach einigem Suchen bin ich dann auf eine Dokumentation zu einem Nanya-Display gestoßen:


    http://www.skippa.de/pdf/014spec.pdf


    4l65h6ji.jpgHier ebenfalls auf Pin20 die Positiv/negativumschaltung via TTL-Pegel. Funktioniert leider nicht :-/


    Zudem ist die Darstellung um exakt einen Pixel nach rechts verschoben.


    Hier mal eine Rückseite des Naya-Displays:


    y6xryzbh.jpg



    Zum Vergleich die Rückseite eines original Toshiba Display:


    hxgqzzep.jpg


    Lightpower verkauft noch Originaldisplays:


    "...das Display ist ein Auslaufmodell, allerdings haben wir noch 5 Stück ab Lager Paderborn zur Verfügung.


    Das Teil hat die Art.Nr. 129931 und kostet 302,-- EUR (abzüglich 10% btb-Rabatt), die Versandkostenpauschale beträgt 6,90 EUR."


    Das lohnt sich ja nicht wirklich.


    Die andere Baustelle, die nicht funktionierenden Tasten, die merkwürdigerweise auf einigen Macrotasten liegen habe ich bisher noch nicht weiter in Angriff genommen, außer zu scheuen wie die Tastenmatrix geschaltet ist, da wäre natürlich ein Schaltplan hilfreich. Hier mal ein Foto der Schieberegister-Chips:


    kbtm82ib.jpg


    also weiterforschen :)


    skippa

  • Sicher, dass das nicht funktioniert? Ist laut Datenblatt einfach nur invertiert zum "Original". Andererseits finde ich das grade cool, wie das inverse Display aussieht.

    Moin,


    ja, ich habe sogar ne Brücke von Pin 20 auf Pin 3 direkt an der Pfostenleiste gelegt, aber die Darstellung bleibt invertiert. Auf der Platine ist JP1 vorhanden, der direkt an Pin20 geht, der ist bestimmt dafür vorgesehen, aber auch das Schließen dieses Jumpers tut nichts, obwohl auf der anderen Seite des Jumpers 5V+ anliegen. Sehr schade... Die anderen Jumper waren schon teilweise geschlossen und andere Abbildungen im Internet legen nahe daß dies so ab Werk ist.


    skippa

  • Also...wenn ich die beiden Datenblätter vergleiche, dann fällt auf, dass die REVERSE Funktion des Originals zum Austauschpanel gerade umgekehrt ist:

    Folglich müsste für Positiv-Darstellung Pin 20 auf dem Austauschpanel auf logisch "0" gelegt werden, nicht auf logisch "1" - oder hab ich jetzt da nen Denkfehler?

  • Also...wenn ich die beiden Datenblätter vergleiche, dann fällt auf, dass die REVERSE Funktion des Originals zum Austauschpanel gerade umgekehrt ist:

    Folglich müsste für Positiv-Darstellung Pin 20 auf dem Austauschpanel auf logisch "0" gelegt werden, nicht auf logisch "1" - oder hab ich jetzt da nen Denkfehler?

    Moin,


    den Weg bin ich auch gegangen, ich habe die Brücke auch mal von 20 auf Pin 2 gelegt - aber da tat sich auch nichts :-(


    skippa

  • Bitte messe mal die VEE Spannung... dann den Pegel am Pin20. Wenn dieser GND Potential hat, auf Durchgang prüfen zum GND. Stecker abziehen nochmal am Pin 20 Messen und dann suchen wo das die Verbindung besteht. Auftrennten mit Pullup 10k hoch legen.


    Bei 5V -> Durchgang zur 5V Seite prüfen -> 1k...10K ok -> nach GND ziehen.


    Ohne diese Maßnahmen passiert entweder nichts oder du baust einen Kurzschluss.


    Du sagtest der Kontrast funktioniert ? Denn laut Datenblatt ist die Funktion des Pin20 genau anderes herum, wie schon festgestellt.

  • Moin,


    also bevor ich da nun durch Unwissenheit womöglich Schaden anrichte habe ich das Nachbaudisplay ausgebaut und ein altes, originales Toshiba eingebaut. Dieses funktioniert einwandfrei, und bei dem Spendegerät ist zudem noch der Inverter defekt. Möglicherweise meldet sich der Hersteller Nanya betreffs der angefragten technischen Dokumentation, dann würde ich da nochmal weiterforschen.


    Nun zu der zweiten Baustelle, den nicht funktionierenden Tasten "Quit", "Options" & Store".


    Witzigerweise ist die "Options"-Funktionalität nun auf der "Macro A" Taste, und die "Quit"-Funktion auf der "Macro-D" Taste. "Edit" funktioniert auf der eigenen Taste, nur "Store" funktioniert gar nicht.


    Alle 8 Taster in dieser Sektion (Außer "Macro-E") gehen über ein Widerstandsarray auf einen Schieberegisterchip vom Typ 74165.


    Kann jemand von euch eine Einschätzung geben wie dieses Phänomen zu deuten ist? Die Taster selbst schalten prima, habe da mal mit einem Multimeter auf Durchgang geprüft. Rein optisch sind einige matte Lötstellen zu erkennen, und die eine oder andere Leiterbahn ist stellenweise oxidiert, aber nicht unterbrochen. Ist ein defekter Schieberegister typisch?


    skippa

  • Moin,


    und wäre das "Schadensbild" dadurch zu erklären? Ich bin ja kein Elektroniker, schon gar kein Digitalelektroniker, aber der Zusammenhang wäre mir zumindestens logisch ;-)


    skippa


    PS: anbei mal ein Bild der Rückseite der Tastensektion:


    z63bg9yu.jpg


    Interessanterweise sind auf dem "options"-taster Lötaugen für eine LED, die es da aber nicht gibt...